martes, 14 de octubre de 2014

Error al actualizar el paquete java-common en Archlinux

 Hoy me he acordado de actualizar Archlinux y me he encontrado un error al actualizar el paquete java-common. Como siempre que ocurre un error en la actualización de Archlinux lo mejor es acudir a la Wiki para mantenernos informados sobre lo que pasa.





 En este caso la solución es muy sencilla. Lo que hay que hacer es teclear los siguientes comandos en el terminal.

pacman -Q java-common
 Este primer comando nos dirá si tenemos java-common instalado y si es así es el causante del problema de actualización, así que continuamos:

sudo archlinux-java unset
sudo pacman -Sydd --asdeps java-runtime-common


 En este momento nos dirá que java-runtime-common y java-common están en conflicto. A la pregunta si queremos quitar java-common le damos que si.

sudo archlinux-java fix

Y ahora ya podemos actualizar tranquilamente con un:

sudo pacman -Su

Mas información aquí.

No hay comentarios:

Publicar un comentario en la entrada