miércoles, 21 de enero de 2015

Error en las firmas PGP en ArchLinux

 Ya llevaba algún tiempo que cuando actualizaba ArchLinux me aparecía el siguiente error.
 Hoy por fin me entraron ganas de resolver este pequeño error que afectaba unicamente al paquete lib32-libcurl-gnutls. Como siempre lo mejor es echar mano de la Wiki de Archlinux, y efectivamente, la solución se encontraba ahí.

  Vamos a nuestra carpeta de usuario y buscamos la carpeta oculta .gnupg (para ver las carpetas ocultas Ctrl + H). Dentro de esta carpeta buscamos y abrimos un archivo llamado gpg.conf.

 Ahora tenemos que buscar una línea que dice esto:
keyserver-options auto-key-retrieve
y quitarle la almohadilla que lleva delante, tal como muestro aquí.
Ahora ya podemos actualizar ese paquete sin problemas.

3 comentarios:

  1. genial, no existia ese archivo de configuracion pero lo creé y pegué adentro la linea en cuestión, y solucionó el problema. Muchas gracias

    ResponderEliminar
  2. Gracias por el aporte. tuve que crear el archivo, pero ya esta solucionado mi problema.

    ResponderEliminar
    Respuestas
    1. De nada. Me alegro de que te haya servido.
      Un saludo.

      Eliminar