viernes, 16 de octubre de 2015

Java 8 para Debian

Hola, os voy a relatar un problema que he tenido y me ha hecho perder mucho tiempo. Resulta que estaba usando la aplicación logisim aunque una versión para la universidad. Logisim es un programa para diseñar circuitos lógicos.






Pues bien esta aplicación libre funciona perfectamente sin embargo la aplicación VerilUOC precisa de la última versión de java. Yo tan contento la instalé, claro está la última versión libre.






Esta versión no da problemas con nada salvo con esta aplicación a la hora de realizar la conexión al servidor con el que debe verificar el ejercicio. Si no tienes la última versión te dará problemas. Esta misma versión, si la usas en Ubuntu no tiene problema alguno, se ve que en Debian debe haber alguna modificación.

Cada vez que intentaba conectar daba un tipo de error que no dejaba nada claro.





Si hablas con alguien que tenga otra distribución diferente a la de Debian, es más que probable que no tenga problema alguno. La forma de arreglarlo me la proporcionó un compañero. Menos mal ya que la opción era montar una máquina virtual y montar Ubuntu pero el PC que tengo ahora es poca cosa. Los días felices con mi i7 pasaron a mejor vida. Como digo el compañero me comentó que podía darse el caso que para Debian no funcionase la versión libre y que siguiera esta página. Así que seguí esos pasos y ya el programa funciona perfectamente conectándose al servidor y corrigiendo los ejercicios realizados.

Así que para instalar la versión de Oracle de java 8 para Debian debemos hacer:


su -
echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main"
 | tee /etc/apt/sources.list.d/webupd8team-java.list
echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main"
 | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886
apt-get update
apt-get install oracle-java8-installer


Si ahora hacemos un java -version veremos qué versión tenemos:



Así que sólo queda comprobar si ahora nos funciona la conexión con el servidor. Antes de nada salimos como superusuario para volvernos al usuario normal y a continuación vamos a la carpeta contenedora del archivo de VerilUOC y lo ejecutamos, intentando conectar.

cd Descargas
java -jar VerilUOC.jar


Si hacemos esto se podrá usar VerilUOC perfectamente y conectarse al servidor para que corrija nuestros diseños.

Muchas gracias a todos los compañeros que han ayudado con soluciones alternativas hasta que el compañero David Doblas que encontró la página y sobre todo al autor de esta entrada.

No hay comentarios:

Publicar un comentario en la entrada