lunes, 7 de marzo de 2016

Problema con yaourt en Antergos

No soy capaz. La verdad es que no soy capaz de estarme mucho tiempo en una sola distribución. Llevaba unos cuantos meses muy feliz con Ubuntu 14.04, todo funcionando de maravilla, pero por no se que extraña razón he decido cambiar de aires. Hace tiempo que lo intenté con Antergos, pero en ese momento no pude instalarla tal como comentaba aquí.
 No voy hacer un análisis de la distribución, ya que llevo poco tiempo con ella, aunque si que le he visto unos defectillos. El primero es lo lento de la instalación, ya que se descarga muchos paquetes. El segundo es el renderizado de las fuentes. No me convence, tendré de ver como se arregla eso. Y por último el problema con yaourt.

 Para aquel que no conozca yaourt, dicho mal y rápido, es un repósitorio comunitario en el cual se sube los programas que no están en los repósitos oficiales de ArchLinux. El caso es que me daba un error al intentar instalar un programa que estuviera alojado en yaourt. Así que no me quedó más remedio que intentar buscar una solución.

 Después de buscar un buen rato la solución la encontré en los foros de Antergos (por otra parte algo obvio). Voy a transcribir la solución. Lo primero de todo es añadir el repositorio de yaourt, así que abrimos una consola.
sudo nano /etc/pacman.conf
Ahora, y antes del repósito de Antergos, añadir el de yaourt de tal forma que quede así:
[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/$arch
[antergos]
SigLevel = PackageRequired
Include = /etc/pacman.d/antergos-mirrorlist
 Ahora desinstalamos yaourt con un:
sudo pacman -Rdd yaourt  package-query
Actualizamos los repósitos con un:
sudo pacman -Syy
Limpiamos la caché:
sudo pacman -Scc
Y volvemos a instalar yaourt:
sudo pacman -S yaourt package-query
 Ahora ya deberíamos poder usar yaourt sin problemas.

Visto en el foro de Antergos.

No hay comentarios:

Publicar un comentario en la entrada